Archive

Archive for November, 2009

Zend Server CE on Ubuntu 9.10

November 13th, 2009 No comments

Here: https://bugs.launchpad.net/ubuntu/+source/openwsman/+bug/462059

Evan Broder wrote on 2009-10-30: #6
The transition wasn’t actually libkrb53 -> libkrb5-3. The old libkrb53 package was split up into several other packages (libkrb5-3 for libkrb5 itself, but also libgssapi-krb5-2, libk5crypto3, and libkrb5support0).

As a temporary fix, you can use equivs to generate a fake transitional libkrb53 package. Run equivs on a file with these contents:

Package: libkrb53
Version: 1.6.dfsg.2+fake1
Depends: libkrb5-3, libgssapi-krb5-2, libk5crypto3, libkrb5support0

then install the resulting .deb.

In the longer term, the libkrb53 dependency in the affected packages was automatically generated at build-time based on what libraries the binaries in the packages linked against. To fix the bug, it should be sufficient to just rebuild the packages with no changes.

The libkrb53 package was intentionally removed fairly early in the Karmic development process, and there was a fairly lengthy process to make sure all the affected packages were rebuilt; I’m not sure why this one got overlooked.

In any case, here’s a patch that will trigger that rebuild. I’ve uploaded a test build to my PPA (https://launchpad.net/~broder/+archive/ubuntu-tests), but it’s pretty backed up right now so it might take a while to finish.

Categories: Computers Tags: